Tech Tools

On Februrary 4, 2014 Adobe released a critical security update for Flash Player. The security update addresses a vulnerability that could allow a remote attacker to take control of a computer. VUIT recommends that you update Adobe Flash Player to the latest version as soon as possible. To obtain the latest version please visit the following link: http://get.adobe.com/flashplayer/


Upcoming Changes to Remote Proctor:

  • MAC OS X 10.6 (Snow Leopard) Support ends as of April 8th, 2014 - New current supported versions will include: 10.7.x (Lion), 10.8.x (Mountain Lion), and 10.9.x (Maverick)
  • Windows XP – Support ends as of April 8th, 2014 - New current supported versions will include: Vista, Windows 7, Windows 8.0 & Windows 8.1

    Click here for more information >>

Select the product you need help with

 


Computer


- Conferencing
    - Microsoft Lync
    - Scopia

- Networking

- Security

- Settings

- Software

- Video

Course Management


- Clinical Log

- OAK

- YES

Electronic Library


- Digital Library

- Ovid
- Tutorials
- UpToDate

Email/VUnetID


- Email
- VUnetID

 

 

Remote Proctor


- FAQ
- Installation
- Purchasing/Selling
- Requirements
- Technical Support

- Testing Policy
- Troubleshooting
- User Group

Turning Point


- Students

- Purchasing

- Registration
- Troubleshooting
- Support
- Instructor/Presenter

Slate


Administrator
- Log in
- Manual
Evaluator
- Log In
- Manual

Support


Directory
- Lab Schedule

- FNIC Video

Kaseya
- Help Ticket

Teamviewer